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TradeStation 95 to 10 Transition Guide
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Welcome to TradeStation 10! Browse these frequently asked questions to learn more about our
updated platform terminology, how to move your workspaces, where your files are now stored,
and where all the key platform features are now located. TradeStation 10 provides significant
enhancements to the platform’s appearance and functionality, and we hope it will exceed your
expectations.
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What platform terminology has changed?

Here is a guide to the terminology updates from TradeStation 9.5 to 10:

Analysis Technique Study

Analysis Group Study Group
Order Bar Trade Bar

Insert (as in Insert Analysis Technique) Add Study
Manage (as in Manage Analysis Technique) Edit Study

Delete Remove

Format (as in Format Symbol) Customize Symbol
Format (as in Format Analysis Technique) Edit Study

Data Interval Timeframe

How do | move my workspaces?

The first time you log in to TradeStation 10, if you have a previous version of TradeStation installed, you
will be prompted to import your work using a step-by-step wizard.

If you choose not to import your work when you first log in, you can import your files later.

To import your work: TradeStation - Untitled Desktop: 1
1. Click File from the ABFILE  EDIT VIEW WINDOW  HELP
menu bar along the top l New Application
of the platform. -
Workspaces
2. Select Backup/Restore Recent Workspaces
TradeStation from the

Desktops
menu.

Preferences

3. Select Restore from

Legacy Version... ool i teon i L
to'open the |lT1DOI’t e Backup/Restore TradeStation & Backup Trade5tation...
Wizard. Import/Export Easylanguage... | Restore TradeStation Archive...
[4 Note: You will not be able to Print (3 Restore from Legacy Version...
use workspaces that are created - ‘ P CTEre e
or modified in TradeStation Manage Simulated Accounts...
10 in previous versions of <F| Wark Online

TradeStation.

Exit



Where are my files stored?

To comply with Microsoft Windows security best practices, TradeStation files are now stored in new
locations. The files that you create, for example your workspaces, have been moved from the Program
Files (x86) directory to the User’'s Documents directory.

The new path will be C:\Users\[UserName]\Documents\TradeStation 10.0, where [UserName] is your
Windows user name. Now, even if your platform is uninstalled, the files you have created will remain in
this location.

| v = | TradeStation 10.0 - U X
Home Share View

* ‘J do Cut X % New item ~ \; J 24 Open ~ Ha Select all
W= Copy path Tj Easy access ™ Edit | Select none
Pinto Quick Copy  Paste Move Copy Delete Rename New Properties i
e — d Paste shortcut 3 o & folder = & History DD Invert selection
Clipboard Organize New Open Select
« v | C\Users\username\Documents\TradeStation 10.0 Vl => | Search TradeStation 10.0 »p
~
Users ~ [ Name 2
Default
erau CAL
AppData CustomSymbolLists
Desktop Data
Documents Desktops
Downloads Easylanguage
Favorites Bt
Reports
Links
Restore
Music Seans
Pictures Sessions
Saved Games StagedOrders
Videos Templates

Where are my TradingApps, Order Bar, and Position Graph Bar?

In TradeStation 10, the Apps (TradingApp Launcher), Trade (Trade Bar, previously called Order Bar),
and Position Graph bars are more customizable. By default, they appear along the top of the desktop.

You can hover your mouse over an application to ,” TradeStation - Untitled Desktop: 1
expand it, or click the + pushpin icon to dock it to
your window's desktop.

FILE EDIT WVIEW WINDOW HELP

Apps Trade Position Graph
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To custornize the way your bars display:

Apps k Position Graph
2 E Equities Symbol Quantity Limit Price Stop Price Order Type  Route Duration Account Number
= AfPL . ()l 500 |= = | Auto i Lmit  ~ |Inteligent ~ |Day+ - -

Buy Sell Sell Short Buy to Cover 0Co/os0 Stage i Default |Advanced >>

3 B:176.44 L:175.46 A:176.45 «Connected> LIVE: Connected to trade server

1. Hover over the docked bar to make it expand. If you move off the docked bar, it will collapse.
2. Pin + the docked bar to expand it, even when you move the mouse off the bar.
3. Re-dock the bar and move it around the desktop by grabbing this section.

For more information about displaying, hiding, and moving bar panels, select Help along the top of
the platform, then select Get Help > Platform Trading from the menu. From the Index tab, type the
keywords Bar Panels to find the topic.

How do the new toolbars work?

You can access all window-specific functionality from the new in-application toolbars and their
matching right-click shortcut menus.

Window-specific toolbars display at the top of an application window, such as Chart Analysis, and
contain buttons that are only applicable to that specific window type.

&4 (Chart Analysis - AAPL Daily [NASDAQ] Apple Inc
Timeframe ing 2 studies (7 sty T o= oll. Data ~ {5}

AAPL - Daily HASDAQ L=

175.00

170.00

165.00

160.00

155.00

150.00

145.00




The right-click shortcut menus match their application toolbars.

#4  Chart Analysis - AAPL Daily [NASDAQ] Apple Inc BEE - o x
- ©n  Drawing - A Studies - (7] « o 1 oll. Data - {53 Settings -
AAPL - Daily M

= 75.00
(o) Timeframe e

Drrawing

Studies

170.00
(] style 165.00
Chart Trading

" 160.00
Background Dragging
Data 155.00

1 co py Window t 150.00

145.00

In addition to displaying the default in-application toolbars, you can create your own custom
toolbars for an application window. For more information on creating a customized toolbar, you can
bring up the TradeStation 10 software and go to Help along the top of the platform, then select

Get Help > Platform Trading in the menu. Under the Index tab, type the keyword Toolbars and select
the subtitle called Customizing.

What is TradeStation Today?

TradeStation Today is an all-in-one dashboard featuring up-to-date educational resources including
market videos, events, and workspaces. Recommended workspaces created by TradeStation and
market gurus extend the power of the platform.

1'. Tfa d EStation (g University TradingApp Store

Market S 0341 :1 5 What's Happening Upcoming Events 6%

TradeStation . s e Feb
. Learning TradeStation - Filtering 07

Symbols and Real-Time Scanning Feb

o ) 08

i : : Feb

% TradeStation’ . 7 O 9
What 2 Watch 4: :

MASTER CLASS ' Feb

Tesla Earnings 1B

Feb

~ 4 b 13

What's New

Station 10 Update 8

SSPX.X 2,600




7o launch TradeStation Today:

Paosition Graph

o B TSToda;re

1. Access the TradingApp Launcher by clicking the Apps tab (at the top edge of your desktop) or
using the View > TradingApp Launcher menu sequence.

2. Click the TS Today icon (next to Search) on the TradingApp Launcher title bar.

How do | apply an indicator to a chart and enable an alert?
In TradeStation 10, to apply an indicator to a chart:

& Chart Analysis - AAPL 5 min [NASDA... [B9) [BF) o o =
- {2) Timeframe - [ Drawing - & Studies - ’_’
Add Studies
elndicatcnr
Showhe
PaintBar
ActivityBar

ProbabilityMap

10:00 11:00 12:00

-

Edit EasylLanguage...|| ™ Import

are intended
curity, group of

1. Along the top of the chart, select Studies, and then select Add Study from the menu. You may
also right-click on the background of a chart and select Studies from the menu.

2. Choose the Indicator tab and select an indicator.

3. To edit the indicator before you insert it, select the Prompt for Editing checkbox. Otherwise,
clear the checkbox to apply the indicator using its default values.

4. Click OK to apply the indicator.
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178.00

177.60

Volume Avg ( 50,50, Cyan , Red ) 1062030.00 1843 ...

Edit "Volume Avg'...

T R T o

11:00 12:00 13:00 1408 =
Disable "Volume Avg'

Remove "Volume Avg'

o Alert Disable Alert
=]

Update value intra-bar Enable Alert Once

g Enable Alert Once Per Bar

Enable Alert Continuously

Edit Easylanguage for "Volume Avg'...
Help
5. Inorder to enable alerts, right-click the study and select Alert from the shortcut menu.

6. Select the Enable Alert setting for the type of messaging you want to use.

¥ Note: The drawing objects that support alerts are Andrews Pitchfork, Fibonacci Tools (except the
Price Retracement Calculator and Speed Resistance Arcs), Gann Fann, Horizontal Line, Vertical Line,
Regression Channel, Time Cycle, and Trendline.

How do | enable and disable non-strategy orders and position arrows
in a chart?

By default, TradeStation will automatically display filled positions arrows in a chart. In order to
disable these filled position arrows, follow these steps:

1. Right-click on the background of a chart analysis window.

2. Select the Settings > Account Orders & Positions menu item. The Customize Account Orders
& Positions dialog opens.



Customize Account Orders & Positions

Data Order

Settings g ition Arrows

Order Lines:

Auwg. Price

[15et as Default

{'E" OK Cancel

3. Select the Settings tab.

4. Remove the check mark from the Display Position Arrows box to disable position arrows.
Add the check mark to enable position arrows.

5. Click OK to save the changes.

For more information on account orders and positions, select Help along the top of the platform,
then select Get Help > Platform Trading from the menu. From the Index tab, type the keywords,
Account Orders and Positions.

How do | view a Strategy Performance Report?

After placing entry and exit strategies on the chart, select Data along the top of the chart, then select
Strategy Performance Report from the menu.

Chart Analysis - MSFT 5 min [NASDAQ] Microsoft Corp

-100 } :'_._' Strategy Performance Report Shift+Alt=P
BBandSE

[7] patawindow Cirl+Shift=D

) Reload Data Ctri+R

Data Corrections 3
BBandLE
- Ap MSFT to Custom Symbol List...

BBandLE
100

13:00 14:00 15:00 I; 11:00 12:00 13:00 14:00 15:00




How do | select different chart data intervals?

A timeframe, or data interval, represents the amount of price action within a bar (from the open to
the close) and is expressed either in terms of time (1 minute, 30 minute, daily, etc.) or trading activity
(tick count or volume). For example, in a daily chart, each bar interval represents the price action

of one day - typically, the bar opens in the morning with the beginning of the trading session and
closes at the end of the trading session in the afternoon, and so on for each bar. However, you can
use any interval for your chart, including non-time-based intervals. There are three types of data
intervals: time-based, tick-based, and volume-based.

In TradeStation 10, to change a timeframe (data interval):

& Chart Analysis - MSFT5 min [NAsD... [B=) @5 - O
MSFT OTimEframE ~ [E» Drawing ~ J. Studies - |
MSFT - 5 min NASDAGQ B=87.76 A=81 ...
i
III | 1
Iy

| ! '
1 LT
‘ : Command Line
|-|

3 rr|ir||

|. PiL: $4.215.00 | 87.30
T .

11:00 12:00 13:00 14:00 15:00

1. Along the top of the chart, select Timeframe, and then select the interval for the specified bar
or chart type.

2. Or type the interval keyword (i.e,, 5 min, 10 min, daily, etc.) and press Enter (the interval
appears in the toolbar's command line). By default, intra-day (time) is displayed when a chart
is created.

New in TradeStation 10, you can add your own Timeframe buttons to your toolbar, so that you can
quickly select your preferred timeframes.

& Chart Analysis - MSFT 5 min [MASDAC] Microsoft Corp £| _| = o =z

>

MSFT - =) Timeframe - [=* Drawing - L studies -



In TradeStation 10, to add a Timeframe button to your toolbar:

&% Chart Analysis - MSFT 5 min [NASD... F-F'__'| FE| -
- _ Timeframe - [ Drawing = /& Studies = 1
MSFT - 5 min HASDAG L=9 10 Ticks
10 Ticks
Style
Decrease Bar Spacing Down
Increase Bar Spacing Up
Chart Trading
Background Dragging

Zoom In

Data

12:00  13:00 b Settings
Customize...

Reset Toolbar

1. Along the top of a Chart Analysis or RadarScreen® window, select Toolbar Options (the
down-arrow on the far right of the toolbar).

2. Select Customize from the drop-down list. The Customize dialog appears.

& Chart Analysis -MSFTsmin[NasD.. R @B) - O x

Timeframe - =7 Drawing - Studies «

Customize

o Commands

Toolbars Timefra
Drawing
Options Studies
I ' Scaling
| "t Style
Data
Settings
Chart Analysis Toolbar

1 Mt

2 Mirutes

12:00

3.
4,
5.
6.

3 Mirutes

Desaiption: 15 Seconds

Select the Commands tab.
Select the Timeframe category.
From the Commands list, click and drag the desired Timeframe button into the toolbar.

Click the Apply button.



s  Chart Analysis - MSFT 15 SecgRar [NASDAG) Micr... (B2 (B - 0O x

MSFT - || () Timeframe (> Drawing - [ Studies - [7] Style -

90.50
90.45
S A )

1

11:28:15 11:38:15

7. Click the Timeframe button you have added to the toolbar to apply the new timeframe.

For more information on intervals, interval/chart types and range, you can bring up the TradeStation
10 software and go to Help along the top of the platform, then select Get Help > Platform Trading in
the menu. Under the Index tab, type the keyword Timeframe and select the topic called Timeframe
(see Data Interval).

Where is the latest list of platform updates?

The latest “What's New” is available in TradeStation Today.
1'. TfadEStation University TradingApp Store
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See “What is TradeStation Today?” above for more information on TradeStation Today.



Do | need to install platform updates myself?

Not anymore. Each time you log in, TradeStation 10 automatically checks to see if there’s a newer
version of the software available - so you don’t have to. You can trade confidently knowing that you
always have the platform’s latest features and upgrades. We've also improved installation speeds for
each update.

How do | find more help and videos?

Jump start your trading on the latest TradeStation with the new platform resource center, where
yoU'll find links to the installation and upgrade quide, weekly live Getting Started demonstrations,
FAQs on transitioning to the new platform, how-to video TradeBites, in-platform help, and our
in-depth Learning TradeStation series.

= Visit the new platform resource center online:
https://www.tradestation.com/university/learning/desktop-resources

IMPORTANT INFORMATION
No offer or solicitation to buy or sell securities, securities derivatives or futures products of any kind, or any type of trading or investment advice, recommendation or strategy, is made, given or in any manner
endorsed by any TradeStation affiliate. Past performance, whether actual or indicated by historical tests of strategies, is no guarantee of future performance or success. Active trading is generally not
appropriate for someone with limited resources, limited investment or trading experience, or low risk tolerance. Please visit our website www.tradestation.com or www.tradestation-international.
com for relevant risk disclosures. Equities, equities options, and commodity futures products and services are offered by TradeStation Securities, Inc. (Member NYSE, FINRA, CME and SIPC).

Options trading is not suitable for all investors. Your account application to trade options will be considered and approved or disapproved based on all relevant factors, including your
trading experience. View the document titled Characteristics and Risks of Standardized Options. Before trading any asset class, customers must read the relevant risk disclosure
statements on our Important Information page. System access and trade placement and execution may be delayed or fail due to market volatility and volume, quote delays,
system and software errors, Internet traffic, outages and other factors.
©2018 TradeStation. All rights reserved.
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